跳到主要內容

CISCO ASA 基本設定










CISCO ASA 防火牆剛拿到的時候可以先接Console進去看show run原本設定,enable password預設沒有。

interface GigabitEthernet1/1
nameif outside
security-level 0
ip address dhcp setroute

interface GigabitEthernet1/2
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0

dhcpd address 192.168.1.5-192.168.1.254 inside
dhcpd enable inside

http server enable
http 192.168.1.0 255.255.255.0 inside

預設是第一port是WAN,第二port是LAN,有發一段DHCP 192.168.1.5-192.168.1.254,HTTP服務是開放的,只允許192.168.1.0/24網段登入,所以這時候我們可以插第二port進去拿到一個DHCP IP 192.168.1.5,點擊瀏覽器 https://192.168.1.1。



這時候你要先去安裝JAVA然後點擊 Install ASDM Launcher ,然後安裝 dm-launcher ,如果出現帳號密碼的話,空白登入即可,我把IP從192.168.1.1改成192.168.2.254,所以截圖不一樣。


接下來就會進入ASDM的主畫面。

Configuration ->  Interface Seting -> Interface,我要設定的是WAN Port,範例IP是 210.242.144.107/24。


Configuration -> Routing ->  Static Routes,設定預設路由,範例是210.242.144.254。



這時候內部網路還不能上網,因為上網一定要做NAT,我們到 Configuration > Firewall > Service Policy Rule > Add裡面的 > Add "Network Object" NAT Rule ,只要是192.168.2.0/24都NAT成Outside Interface IP,用 Dynamic PAT作。



我們測試電腦目前可以上網,但是ping不通,因為ASA預設沒有開放ICMP服務。



Configuration > Firewall > Service Policy Rules編輯預設的規則,頁籤 Rule Actions,把 ICMP相關打勾,確定。



驗證確實可以ping到 HINET DNS。



Configuration > Firewall > Access Rules 最後檢查政策,ASA 有 security-level 的概念,數字多少可以自己訂,常見的是 LAN 是100最安全,DMZ數字在0~100中間,WAN是 0 最不安全,預設數字大的介面可以到數字小的介面,但是數字小的介面沒辦法到數字大的介面,所以訂好之後預設 LAN 可以到 WAN ,但是 WAN 不能到 LAN ,這也是為什麼我們到現在都沒有設定 Policy 還是可以上網,ASA 最後隱藏一條deny any。



























留言

張貼留言

這個網誌中的熱門文章

FortiGate 網路基本設定

這是Fortigate小台型號60D,他沒有一般的USB console port,所以我們要用mini USB搭配官方軟體FortiExplorer,軟體模擬console登入。



FortiExplorer可以到官方下載,http://www.fortinet.com.tw/resource_center/product_downloads.html 。

USB和軟體都安裝好插入之後他會自動開啟。



進入Command-line Interface,主要是看出廠預設的設定檔。

 edit "lan"
        set vdom "root"
        set ip 192.168.1.99 255.255.255.0
        set allowaccess ping https ssh http fgfm capwap
        set type switch
        set listen-forticlient-connection enable
        set snmp-index 10
    next

這說明了我們可以插在lan port然後透過192.168.1.99 web介面去管理。



設定192.168.1.0/24同網段,插在lan port上然後連https://192.168.1.99,預設帳號密碼是 admin 沒密碼。



先到Netwok Interface裡面編輯Wan1,就是跟我們小烏龜接的地方,這次範例是用PPPOE撥號連線。



輸入好Hinet提供的連線方式,按下OK,這裡要特別注意一個選項 Retrieve default gateway from server ,一定要打勾,他才會把PPPOE拿到的Default Gateway寫入路由表,不然會沒有Default Gateway可以到ISP。



確實拿到一個浮動IP 111.243.63.46。



這時候其實修改Software Switch lan的內部Default Gateway IP就可以了,但是我們仔細觀察一下。

Software Switch lan裡面的成員有 wifi 和 internal。
Hardware Switch internal裡面的成員有 internal1~ interna…

交換器Console的連線方法

如果我們要進去交換器打指令的話,通常都是使用console port。



購買產品的原廠通常都會送一條console線,Cisco和大多數廠商像是 D-link和Zyxel都通用,但是我有遇過Sonicwall 腳位不太一樣,所以不能通用,算是很少數。



舊的主機板後面都有 DB9 的母頭,所以Console線是 DB9 的公頭,插入就可以用了。



筆電因為沒有DB9的接頭,所以我們會買一條 RS232 轉 USB 線來用,就像現在超薄筆電很少有網路孔所以都是用USB轉網路孔。



所以最後接起來我們會拿到一條RJ45對USB的線。



接上筆電之後,要到裝置管理員找連接埠,如果看到驚嘆號的話表示沒有找到驅動程式,要到 RS232 轉 USB 的製造廠商的官網去下載安裝,我測過Win10的相容性已經很好了,通常都是隨插即用,COM數字多少是浮動的,所以每次要連線前最好先進來確認一下。



最後還要去看交換器連線 baud rate 多少,常見的為9600、57600、115200,不相同的話還是可以連,可是會出現亂碼。



連線軟體隨個人喜好,像PuTTY就是一款免費的軟體,有些人會偏好付費的SecureCRT,我們按照此設定連線。



測試連線成功了,我們終於可以打指令設定交換器。



COM不是只能同時有一個喔,像我為了要同時設定多台,我買了二個RS232一轉四COM的裝置,所以我可以開八個PuTTY來連線八台交換器。

Windows AD 架設

首先先改Windows Server 電腦名稱為DC01,然後重開機。



AD的架構是要透過DNS解析的,所以我們把慣用DNS伺服器指向自己 127.0.0.1 。



新增角色及功能精靈裡,點選Active Directory 網域服務。



安裝好之後點選伺服器管理員上方驚嘆號部屬後設定,來設定AD。



我們點選新增樹系,此範例的網域名稱為corpnet.lin0204.tw。



這裡可以看到因為AD的服務和DNS是綁在一起的,所以一定要安裝,DSRM是一個救援修復模式密碼可以給之後記起來,不太會用到。





NetBIOS 網域名稱預設是會取最左邊的單字,所以以此範例來說是 corpnet ,但不好識別,我們改成lin0204。





接下來就等安裝完成重開機。



我們這邊有一台用戶端電腦要加入網域,首先先把DNS指向DC01那台,不然沒辦法解析AD。



電腦名稱為PC01,加入到網域 corpnet.lin0204.tw。



加入網域必須要授權,我們給他administrator的密碼。



重開機之後,第一個畫面是登入 PC01\user 的密碼,這個是本機帳號,但我們要登入網域帳號,所以必須按切換使用者。



我們使用 netbios\帳號 的方式登入,所以是 lin0204\administrator 。



我們用指令 whoami 確定目前的電腦登入帳號為 lin0204\administrator ,並且此台用戶端電腦有加入網域。



我們回到DC01,然後使用工具,Active Directory 使用者和電腦工具。



加入網域的電腦預設會放在 Computers的容器(OU)裡,所以我們看到PC01。



網域控制站則會放在 Domain Controllers 的容器(OU)裡,所以我們看到有一台DC01。



我們前面有提到網域的架構和DNS是習習相關的,畢竟名稱解析都要靠DNS幫忙,所以加入網域的電腦名稱預設會自動登記在DNS裡,大家才解析的到。